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Image ProcessIng 

and multImedIa 

systems

   Unit OUtcOme

 Students will be able to:

  understand the concept of image processing;

   differentiate image file format;

  recognize the function of image processing software;

  recognize interface layout of image processing software;

  edit images properly using image processing software.

5.1 OVERVIEW OF IMAGE PROCESSING

In this sub-unit, we will have an overview of image processing.

l overview of Image Processing

An image can be the one generated by you on the computer screen or available using a scanner/camera. 
The field of digital image processing refers to processing digital images by means of a digital computer. A 
digital image is composed of a finite number of elements, each of which has a particular location and value. 

Pixel is the term used most widely to denote the elements of a digital image. Figure 5.1 shows a digital 
image in Photoshop CS5.

Fig. 5.1: A digital image

 The fundamental steps in digital image processing are:

 Image acquisition: It could be as simple as being given an image that is already in digital form. Generally, 

the image acquisition stage involves preprocessing, such as scaling.

Unit 5   
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 Image enhancement: It is the process of manipulating an image so that the result is more suitable than 

the original for a specific application.

 Image restoration: It is an area that also deals with improving the appearance of an image.

 Color image processing: It is an area that has been gaining in importance because of the significant increase 

in the use of digital images over the Internet.

 Wavelets: These are the foundation for representing images in various degrees of resolution.

 Compression: It deals with techniques for reducing the storage required for saving an image, or the 

bandwidth required to transmit it.

 Morphological processing: It deals with the tools for extracting image components that are useful in the 

representation and description of shape.

 Segmentation: These are the procedures which partition an image into its constituent parts or objects.

 Representation and description: These almost always follow the output of a segmentation stage, which 

usually is raw pixel data, constituting either the boundary of a region (i.e., the set of pixels separating one 

image region from another) or all the points in the region itself. 

 Recognition: It is the process that assigns a label (e.g., “My Image”) to an object based on its descriptors.

 Figure 5.2 shows the basic components of a typical general-purpose system used for digital image 

processing.

Fig. 5.2: Components of a general-purpose image processing system

l definition of Image Processing

Image processing is the set of computational techniques for analyzing, enhancing, compressing, and 

reconstructing images, generally with a digital computer. 

 Its main components are importing, in which an image is captured through scanner or digital camera; 

analysis and manipulation of the image, accomplished using various specialized software applications; and 

output (e.g., to a printer or monitor). 

 Image processing is used in many areas, for example, astronomy, medicine, industrial robotics, and 

remote sensing by satellites.
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l Image Processing software

Image processing software is used for organizing, retouching, and editing images that have been saved on 

CDs and DVDs, scanned in, or transferred directly from the camera to PC.  This software allows you to 

edit and crop out unwanted “strangers”, remove the red-eye effect, or put one person’s head on another 

person’s body. Some of the useful image processing software programs are: 

 (i) Dxo Optics Pro (ii) MS-Paint (iii) Capture One Pro

 (iv) Photo Styler (v) Bibble (vi) Photo Explosion

 (vii) Picture Windows Pro (viii)	Picture Project (ix) Photo Editor 

 (x) Photoshop 

 Photoshop is a popular image processing software that provides numerous tools for editing an image.

Image processing software allows you to retouch photographs, adjust the contrast and the colors and 

add special effects, such as shadows.

l Image File Format

The still images in print and multimedia programs are in digital format. There are two basic forms of 

computer graphics: bitmaps and vector graphics.

 Bitmap images are formed from a matrix of pixels with different colors. These images have large file 

sizes that are determined by the image’s dimensions in pixels and color depth. To reduce this problem, some 

graphic formats such as GIF and JPEG store the images in compressed format.

 Vector graphics are really just a set of graphical objects such as lines, rectangles, ellipses, arcs, or curves, 

called primitives in the image. Draw programs, also called vector graphics programs, are a format widely 

used by computer-aided programs to create detailed engineering and design drawings, and have become 

popular in multimedia for 3D animation.

 Some of the image file formats are:

 (i) BMP (Bitmap) (ii) GIF (Graphics Interchange Format)

 (iii) JPEG (Joint Picture Experts Group) (iv) PNG (Portable Network Graphic)

 (v) TIFF (Tagged Image File Format) (vi) WMF (Windows Metafile)

Activity 5.1
List and ExpLain thE diffErEnt fiLE formats Gif, JpEG, Bmp and tiff.

In small groups, the students will list and explain the different file formats GIF, JPEG, BMP and TIFF.

File Formats

We can use a variety of file formats in image processing and multimedia systems. Some of the more common 

formats are listed and explained below:

	 1. GIF (Graphics Interchange Format): It is pronounced “jif”, supports upto 256 colours (8 bits per pixel). 

It is a compressed format that keeps file sizes smaller. This format is widely used on the Web since files 

can be sent faster than many other formats and groups of them can be animated. Files in this format 

have the extension .gif.
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 2. JPEG (Joint Picture Experts Group): It is pronounced “jay peg”. It supports 16.7 million colors (24 bits 

per pixel). The images are in compressed format so file sizes are even smaller than GIF files. Files in this 

format have the extension .jpg.

 3. BMP (Bitmap): It is a standard uncompressed format for Microsoft Windows and IBM OS/2. Stores files 

as a series of dots, or pixels. It has a maximum of 16.7 million colors (24 bits per pixel) and files have 

the extension .bmp.

 4. TIFF (Tagged Image File Format): It stores compressed files with a flexible number of bits per pixel. It 

provides the highest quality but has large file sizes. This format supports 16.7 million colors (24 bits per 

pixel) and files have the extension .tif.

5.2 BASICS OF IMAGE PROCESSING

In this sub-unit, we will learn the basics of image processing:

l getting started

As mentioned earlier, to process images you need an image processing software. Adobe Photoshop is an 

image processing software which was developed in 1990. It is a leading product in its category, which is 

used by all serious photographers and publishers. Since, 2003 Photoshop CS and new releases integrate a 

complete suite of products to create and edit images or for designing and authoring a website. Think about 

something artistic and graphical, it can do it! 

 Among all advantages of Photoshop, it has the ability to manipulate layers, masks, contact sheets 

and blue prints, to merge them, separate images or align them with accuracy to enhance faint details or 

suppress artifacts. 

 Here, we will use Adobe Photoshop CS5 software for image processing.

l opening and setting up a new document

To open Photoshop,

 Click Start → All Programs → Adobe Photoshop CS5

 The Photoshop opening screen will appear (see Fig. 5.3).

Fig. 5.3: Photoshop opening screen
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 In few moments the Photoshop main screen appears (see Fig. 5.4) on which you will have to work.

Fig. 5.4: Photoshop CS5 main screen

 The main screen displays on top a menu and an option bar (which parameters adapt dynamically 

according to your selection), a toolbox at left (including tools like selector, lasso, magic wand, paint bucker, 

eraser, brush, blur, clone, move, text, colors, etc, themselves often subdivided in several tools), and palettes 

at right (last actions, layers, colors, styles, masks, etc). In-between lies the image window. Most tools are 

associated to a shortcut key (lasso with L-key, etc).

 Useful Tip

You can enlarge the right-hand panes by dragging the separator bar between the panes and the main content 

area.

 To open and setup a new document, perform the following steps:

 1. Click File → New. It will open the New dialog box (see Fig. 5.5).

Fig. 5.5: New dialog box
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 2. Choose a desired option from Preset such as Default Photoshop Size, U.S Paper Photo, and Web etc. 

Set the Size of Preset as your need.  Here, we have selected Photo Preset and set the Photo Size to 

“Landscape 5” × 7” (see Fig. 5.6).

Fig. 5.6: Selecting Preset and Background contents

 3. Click OK. It will setup the new document (see Fig. 5.7).

Fig. 5.7: A newly setup document

 Now, you can add graphics and text in the document as per your need.
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 1. You can manage files with Adobe Bridge. If you are asked whether to start Bridge at login, then 

click No.

 2. Adobe Community Help is constantly updated. Download it, if you want.

l creating an Image

Let us discuss some drawing tools before creating an image:

 Brush Tool: It is used for free hand drawing and is available in the toolbar (see Fig. 5.8).

Fig. 5.8: Brush Tool

 Horizontal Type Tool: It is used to enter the text in the image and is available in the toolbar  

(see Fig. 5.9). 

Fig. 5.9: Horizontal Type Tool

 Rectangle Tool: It is used to draw various shapes in image and is available in the toolbar  

(see Fig. 5.10).

Fig. 5.10: Rectangle Tool

 To create an image, perform the following steps:

 1. In the recently opened new document, click on the Brush Tool.

 2. Hold the mouse button on the work area and make the text or drawing you want.

 3. Click on the Horizontal Type Tool button from the tool bar (see Fig. 5.11) and make a text box on the 

image area. Enter the shape text you want. 

Fig. 5.11: Text toolbar

  You can also format the text like changing the font, Alignment of text; Size and Color of text from 

the text tool bar placed horizontally on the top of work area.
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 4. Click on the Rectangle Tool button in the shape toolbar (see Fig. 5.12). 

Fig. 5.12: Shape toolbar

  Draw the shape you want. You can also select other shapes like Round, Rectangle, Ellipse, Line and 

Custom shape from the toolbar on top of work area.

  We have drawn the image as shown in Fig. 5.13.

Fig. 5.13: A drawn image

l saving Image document

To save the image document, perform the following steps:

 1. Click File → Save

     or

  Press Ctrl + S

  The Save As dialog box will appear.

 2. Set the file type to image format such as .jpg, .bmp.

 3. Type the file name and click on Save button (see Fig. 5.14).
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Fig. 5.14: Save as dialog box

 4. It will open the JPEG Options dialog box. Set the Quality in Image Options and click OK  

(see Fig. 5.15).

Fig. 5.15: JPEG Options dialog box

 The image file will be saved in the selected directory.
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l Interface layout

The Adobe Photoshop workspace includes the command menus at the top of your screen and a variety of 

tools and panels for editing and adding elements to your image. You can also add commands and filters 

to the menus by installing a third-party software known as plug-in modules.

 Photoshop works with bitmapped, digitized images (that is, continuous-tone images that have been 

converted into a series of small squares, or picture elements, called pixels). You can also work with vector 

graphics, which are drawings, made of smooth lines that retain their crispness when scaled. You can 

create original artwork in Photoshop, and you can import images into the program from many sources, 

such as:

 (i) Photographs from a digital camera

 (ii) Commercial CDs of digital images

 (iii) Scans of photographs, transparencies, negatives, graphics, or other documents

 (iv) Captured video images

 (v) Artwork created in drawing programs

 Figure 5.16 shows the Adobe Photoshop CS5 interface.

Fig. 5.16: Adobe Photoshop CS5 interface

 Application bar is displayed at the top of the screen. In the Application bar are the Photoshop application 

icon, the main menu (Windows only), application controls, View controls, the workspace switcher, and a 

button to access CS Live. Below the Application bar is the Options bar, with the Tools panel on the left, 

panels, and one or more document windows that are opened separately.

 The main menu across the bottom of the Application bar organizes commands in individual menus.

 The Options bar displays options for the currently selected tool.

 The document window displays the file you are working on.

 The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. 

Related tools are grouped together.
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 Panels help you monitor and modify your work. An example is the Layers panel.

 Certain panels are displayed by default, but you can add any panel by selecting it from the Window 

menu. Many panels have menus with panel-specific options. You can separate, group, stack, and dock 

panels into your preferred layout.

 1. Drag the panel group by the title bar, rather than by the tab.

 2. To demonstrate the live workspace feature, switch to My workspace and rearrange the panels. 

Then switch between Essentials and My workspace; switch to the Essentials workspace when 

finished.

l Inserting Image from a File or other device

We can insert image from a file or other devices such as scanner, webcam or digital camera. 

 To insert an image from file, perform the following steps:

 1. Click File → Open.

 2. The  Open dialog box will appear. Select the image you want to open and click Open button  

(see Fig. 5.17).

Fig. 5.17: Open dialog box
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 The selected image will be inserted in the document window (see Fig. 5.18).

Fig. 5.18: Inserted image from a file

 For inserting image from other devices click File → Import → Sony Webcam. The picture will be inserted 

in the document window.

 Useful Tip

Press Ctrl + + (Ctrl + plus sign) to zoom in and press Ctrl + – (Ctrl + minus sign) to zoom out.

5.3
BASIC IMAGE EDITING (CROPPING, RESIZING, CORRECTING, 

SHARPENING/SOFTENING)

In this sub-unit, we will learn basic image editing.

l Basic Image editing

The basic image editing techniques are useful when working with digital scans of images. We can apply 

these basic techniques in a wide variety of image editing situations.

 The basic image editing involves the following:

 (i) Adjusting tonality, the black, grey and white Levels in an image.

 (ii) Adjusting the range of colors within an image, its Color Balance.
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 (iii) Cropping an image, creating a new file containing only a portion of the original.

 (iv) Resizing an image, creating a new file with different proportions than the original.

 (v) Saving or Undoing changes you have made.

l cropping 

Cropping is the process of removing portions of an image to create focus or strengthen the composition. 

You can crop an image using the Crop Tool and the Crop command. You can also trim pixels using the Crop 

And Straighten and the Trim commands.

 To crop an image, perform the following steps:

 1. Open the image file you want to crop and click on the Crop Tool from Tools panel (see Fig. 5.19). 

Fig. 5.19: Crop Tool

 2. Click and drag the mouse button to make a crop box (see Fig. 5.20). 

Fig. 5.20: Getting ready to crop an image
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 3. Press the Enter key to crop the image. The selected area of image will be cropped (see Fig. 5.21).

Fig. 5.21: A cropped image

l resizing 

There will be times when you need to make an object bigger or smaller as you copy it from one picture 

to another.

 To resize an image, perform the following steps:

 1. Open the image file you want to resize. 

 2. Click Image from the Menu bar and then select Image Size…. 

  It will open Image Size dialog box (see Fig. 5.22). 

Fig. 5.22: Image Size dialog box
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 3. Set new image size using Pixel Dimensions or Document Size and click OK.

  The image will resize as per your entered dimensions (see Fig.  5.23)

Fig. 5.23: A resized image

l correcting 

Adjusting proper intensity, contrast range, and color balance is very easy using image processing programs. 

Suppose, we want the color adjustment.

 To adjust the color balance, perform the following steps:

 1. Open the image file.

 2. Click Image from the Menu bar → Adjustments → Color Balance.

  It will open Color Balance dialog box (see Fig. 5.24). 

Fig. 5.24: Setting the color balance
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 3. Set your desired color balance and click OK.

 After setting color balance the image will look as shown in Fig. 5.25.

Fig. 5.25: Image after setting color balance

l sharpening/softening

Generally, a scanned image is not as sharp as you might wish. Sometimes you may get very sharp image. 
So, you may require sharpening/softening of the image. First of all open the document having the image 
to sharpen/soften.

 For sharpening an image, 

 Click Filter from the Menu bar → Sharpen.

 The options available are: Sharpen, Sharpen Edges, Sharpen More, Smart Sharpen and Unsharp Masks.

 Select the desired option. The image will sharpen.

 For softening an image,

 Click Filter from the Menu bar → Blur.

 The options available are: Average, Blur, Blur More, Box Blur, Gaussian Blur, Lens Blur, Motion Blur, Radial 

Blur, Shape Blur, Smart Blur and Surface Blur.

 Select the desired option. The image will soften.
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Activity 5.2
scan a photoGraph and Edit in thE dEsirEd sizE and coLor

Students will scan a photograph and edit in the desired size and color.

1. First of all, you will have to scan an image through a scanner. 

 To scan an image in Photoshop,

 Click File → Import → HP Scanner.

 It will scan the image placed in the scanner and display it in document.

2. Now resize the image to a standard photo size (7x5) and adjust its color balance (see Fig. 5.26).

Fig. 5.26: Editing a scanned image

 3. You can also balance the Selective Color.

 To balance the selective color,

 Click Image → Adjustments → Selective Color…. The Selective Color dialog box opens (see Fig. 5.27). 

Fig. 5.27: Selective Color dialog box

 Set the color balance and click OK.



Unit 5 – Image Processing and Multimedia Systems

110   Information Communication Technology — Grade 11 Student Textbook

 After adjusting size and color, the scanned image will look as shown in Fig. 5.28.

Fig. 5.28: Image after balancing the Selective Color

4. To balance the Brightness/Contrast, 

 Click Image → Adjustments → Brightness/Contrast. 

 The Brightness/Contrast dialog box opens.

 Set the Brightness/Contrast and click OK (see Fig. 5.29).

Fig. 5.29: Setting the Brightness/Contrast

 The image will look as shown in Fig. 5.30.
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Fig. 5.30: Image after balancing Brightness/Contrast

  Key ConCepts

  Pixel is the term used most widely to denote the elements of a digital image.

  Image processing is the set of computational techniques for analyzing, enhancing, compressing, and reconstructing 

images, generally with a digital computer. 

  Photoshop is a popular image processing software that provides numerous tools for editing an image.

  The basic image editing techniques are useful when working with digital scans of images. We can apply these 

basic techniques in a wide variety of image editing situations.

  Cropping is the process of removing portions of an image to create focus or strengthen the composition.

Review Questions

Fill in the Blanks

 1. The field of ...................................... refers to processing digital images by means of a digital computer.

 2. ...................................... software is used for organizing, retouching, and editing images that have been 

saved on CDs and DVDs, scanned in, or transferred directly from the camera to PC.

 3. ...................................... is the process of removing portions of an image to create, focus or strengthen the 

composition.  

 4. ...................................... is the process of making an object bigger or smaller.

State Whether True or False

 1. Image enhancement is the process of manipulating an image so that the result is more suitable than the 
original for a specific application.

 2. Adobe Photoshop is not a popular image processing software.
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 3. In Photoshop, Brush Tool is used for free hand drawing and is available in the toolbar.

 4. We cannot resize an image using image processing software.

Multiple Choice Questions

 1. Which of the following area(s) use image processing?

  (a) Astronomy (b) Medicine  (c) Industrial robotics (d) All of these

 2. Which of the following image processing software can be used to retouch photographs, adjust the contrast 
and the colors and add special effects, such as shadows?

  (a) Photoshop (b) MS-Paint (c) Photo Editor (d) All of these

 3.  Which of the following is not an image file format?

  (a) GIF (b) JPEG (c) DOCX (d) TIFF

 4. Which of the following is/are free hand drawing tool(s) available in Adobe Photoshop CS5?

  (a) Brush Tool   (b) Horizontal Type Tool

  (c) Rectangle Tool   (d) All of these

Match the Following

Column A Column B

1. Pixel (a) Correcting

2. Basic image editing technique (b) Basic term used most widely to denote the elements 

of a digital image

3. BMP (c) An image processing software

4. Photo Styler (d) An image file format

Answer the Following

 1. Define image processing. List and explain different types of image file formats.

 2. How will you open and setup a new document in Photoshop? Also give the steps to save an image 

document.

 3. List and explain common interface layout of image processing software, e.g., Photoshop.

 4. How will you edit an image in a desired way?

Suggested Activities

 1. Give a brief explanation of image processing.

 2. Describe about image processing software and its function.

 3. Demonstrate and explain the properties to be set in a document.

 4. Set up a document like Page size and orientation, Resolution, Colour mode and Background content.

 5. Edit image with cropping like Cropping with the crop tool, Cropping to a specific size, and Cropping 
with the marquee tool.

 6. Resize image like Resizing to a specific size, Resizing Digital photo and Enlarging.

 7. Correct image like Red Eye Removal, Hot Spot Removal, Adding Flash, and Colour Adjustment.

 8. Scan your photograph and edit it in the desired size and colour.

 l Resources: Computer, Image Processing Software, Scanner, Digital Camera.

Field Trip

 Organize a field trip to various business houses and publications around you to get useful information about 

Image Processing and Multimedia Systems being used currently and present it in the class.
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Glossary

A

 Absolute Reference: Commonly used in 
spreadsheet applications, it is a formulated cell 
reference that will not adjust when used to calculate 
the sum of specific cells.

 Address Book: In e-mail, list of regular contacts’ 
addresses held in the e-mail software.

 AI (Artificial Intelligence): It is the branch of 
computer science concerned with making computers 
behave like humans.

 Animation: The display of a sequence of images 
in a computer program or on a Webpage to give the 
impression of movement.

 Application Software: A program that is designed 
to perform specific tasks.

B

 Backup: To copy files or data to a second source or 
media so as to safeguard it. 
 Binary: A basic numbering system consisting of 1s 
and 0s. 
 BIt (Binary DigIt): It is the smallest unit of 
processing of computerized data in terms of 1s or 0s.
 Blog: (Slang term for a Weblog) A blog is a personal 
journal that can be accessed publicly and allow people 
to comment on the previously posted comments.
 BMP (Bitmap): It is a standard uncompressed 
format for Microsoft Windows and IBM OS/2.
 Browser: Software program that allows the user to 
find and read encoded information in a form suitable 
for display especially on World Wide Web.
 Byte: A combination of 8 bits to represent computer 
data transfer or data storage measurement. 

C

 CD-ROM (Compact Disc Read-Only Memory): 
A durable and low cost circular optical storage device 
widely used to store large amounts of information.

 Clipart or Clip Art: A collection of image files that 
can be embedded or inserted into Web pages, word-
processed documents, PowerPoint presentations, etc.

 Compiler: A type of system software that translates 
a source program usually written in a high level 
language into a machine language.

 Computer Program: A set of instructions that the 
computer carries out to perform a given task.

 Cropping: The process of removing portions of an 

image to create focus or strengthen the composition.

D

 Data: A collection of raw facts and figures or a 
raw input which when processed or arranged makes 
meaningful output.

 Database: A structured collection of data that can 
be used for a variety of purposes.

 Defragmenter Utility Program: It finds all the 
scattered files on the hard disk and reorganizes them 
as contiguous files.

 Desktop Publishing (DtP): Application software 
for laying out text, graphics and pictures in order to 
produce a professional-looking publication.

 Digital Device: A device that works with discrete 
numbers or digits.

 Disk Fragmentation: The scattering of portions of 
files about the disk in nonadjacent areas, thus greatly 
slowing access to the files.

 Disk Cleanup Utility: It can search for and remove 
unnecessary files such as temporary files, or “temp 
files”.

 DSS (Decision Support System): A computer-
based information system that provides a flexible tool 
for analysis and helps managers focus on the future.

 DVD: Digital Versatile Disc or Digital Video Disc.

E

 E-Commerce: Buying and selling or business 
transaction conducted on the Internet.

 Electro Static Discharge (ESD): The release of 
static electricity when two objects come into contact.

 EPROM: Erasable Programmable Read-Only 
Memory (“ee-prom”). It is a memory chip whose 
contents can be erased by a mechanism using ultraviolet 
light and reprogrammed for other purposes.

 Ergonomics: The study of the interaction between 
people and machines.
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 ESS (Executive Support System): An easy-to-
use Decision Support System made especially for top 
managers; it specifically supports strategic decision 
making.

F

 Forms: Used to provide an easy to use interface for 
user to enter, view and modify data in a table.

 Format Painter: Helps to copy the format that has 
been applied to text and apply it to another.

 FtP (File transfer Protocol): A software protocol 
for exchanging information between computers over a 
network.

G

 GIF (Graphics Interchange Format): It is 
pronounced “jif”, supports upto 256 colours (8 bits per 
pixel).

 Gigabyte (GB): 2 to the 30th power (1,073,741,824) 
bytes. One gigabyte is equal to 1,024 megabytes. 

 GUI (Graphical User Interface): A program 
interface that takes advantage of the computer’s 
graphics capabilities to make the program easier to 
use. Well-designed graphical user interfaces can free 
the user from learning complex command languages.

H

 Hacker: A person who spends his/her time trying 
to gain access to information stored on other people’s 
computers all around the world.

 Hardcopy or Hard Copy: Printed output from a 
computer, as opposed to output on screen.

 Home Page: The initial page of a site on the World 
Wide Web.

I

 Icon: A picture or symbol to represent a command 
on a computer screen.

 Image Processing: The set of computational 
techniques for analyzing, enhancing, compressing, 
and reconstructing images, generally with a digital 
computer.

 Information: Meaningfully organized data.

 Information System: A system that provides 
information to people in an organization.

 Internet Explorer: A browser produced by the 
Microsoft Corporation and supplied together with the 
Windows operating system.

 Internet: The Internet is a network of networks 

all of which use the same set of communications 
protocols. 

 ISP (Internet Service Provider): A company that 

provides access to the Internet.

J

 JAVA: A high-level programming language 
developed by Sun Microsystems.

 Joystick: A device that looks a bit like a gear lever 
in a car. This is connected to a computer and is used 
mainly for controlling the cursor in fast action games.

 JPEG (Jont Picture Experts Group): It is 
pronounced “jay peg”. It supports 16.7 million colors 
(24 bits per pixel).

K

 Keyboard: An input device which is used to 
enter information which the computer displays or 
processes.

 Kilobyte (KB): This is about a thousand bytes of 
space. In reality, it is two to the 10th power or 1,024 
bytes.

L

 LAN (Local Area Network): A network that 
links together computers and peripheral equipment 
within a limited area, such as a building or a group of 
buildings.

 Login: To attach to a computer using the user’s 
ID.

M

 Megabyte (MB): About a million bytes of space. 
Actually it is 2 raised to the 20th power or 1,048,576 
bytes of space.

 Memory: Internal storage areas in the computer.

 MIS (Management Information System): A 
computer-based information system that uses data 
recorded by Transaction Processing System as input 
into programs that produce routine reports as output.

 MPEG (Motion Picture Experts Group): A format 
to make, view, and transfer both digital audio and 
digital video files.

 MS-Access: Database application software, 
provided by Microsoft.

 MS-Excel: Spreadsheet application software, 
provided by Microsoft.

 MS-PowerPoint: Presentation software, provided 
by Microsoft.
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 MS-Word: Word processing application software, 
provided by Microsoft.

 Multimedia: The integration of two or more types 

of information (text, images, audio, video, animation, 

etc.) in a single application.

N

 Navigation: It is the process of finding the way, 
i.e., navigating, around a series of menus within a 
computer program or finding the way around the 
World Wide Web by means of a browser.

 Netiquette: The rules of etiquette that apply when 
communicating over computer networks, especially 
the Internet. 

 Node: In networks, a processing location. A node 
can be a computer or some other device, such as a 
printer.

O

 OAS (Office Automation System): It combines 
various technologies to reduce the manual 
labour required in operating and efficient office 
environment.

 Offline: Not connected to a computer or network 
of computers.

 Online: Connected to a computer or network of 
computers, especially the World Wide Web.

P

 PDF (Portable Document Format): A technology 
developed by Adobe and was designed to capture all 
of the elements of a printed document and place it in 
a single image file.

 Pixel: The smallest element of an image that can be 
individually processed in a video display system.

 Plotter: A computer output device that draws 
images on paper using a pen.

 Podcasts: Online broadcasts that can be downloaded 
to portable devices.

 Portal: A Webpage, website or service that acts as 
link or entrance to other websites on the Internet.

 Printout: Anything produced on a printer after 
being processed by a computer program.

 Primary Key: A set of one or more values in a 
database that uniquely identifies a record in a table.

 Protocol: A set of rules governing the format of 
messages that are exchanged between computers.

 Public Domain: Material that is copyright free, 
whose copyright has expired, or which cannot be 
copyrighted.

Q

 Query: Used to retrieve information on a certain 
condition from a database.

R

 RAM (Random Access Memory): A volatile 
computer memory available to the user for the 
temporary storage and manipulation of data. 

 Relative Reference: The default reference in a 
spreadsheet package.

 Resolution: A measure of the number of pixels or 
small dots displayed on a computer display screen, 
printer or scanner.

 ROM (Read-Only Memory): A memory in which 
program instructions, operating procedures, or other 
data are permanently stored, generally on electronic 
chips during manufacture, and that ordinarily cannot 
be changed by the user or when power is switched 
off.

S

 Scanner: A device used to convert hard copy, e.g., 
a printed page, photograph or photographic negative, 
into a form that can be stored on a computer.

 Search Engines: A computer program that 
searches documents, especially on the World Wide 
Web, for a specified word or words and provides a list 
of documents in which they are found.

 Sheet tab: In spreadsheet applications, this refers 
to a tab at the bottom of a worksheet that acts as a 
means to identify or access different sheets within a 
workbook.

 Slide Show: Used to display the slides in a desired 
sequence.

 Software: The set of instructions used to direct 
the operation of a computer, as well a documentation 
giving instructions on how to use them.

 Social Networking: The grouping of individuals 
or organizations into specific groups.

 Source Code: Program code written in a high level 
language.

 Source data: Data for which the chart is prepared.

 Spreadsheet: A document which helps to organize 
data in rows and columns that intersect to form cells.
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 System: Collection of related components that 
interact to perform a task in order to accomplish a 
goal.

 System Software: It is a set of master programs 
that keeps the computer system working. 

T

 task bar: The bar that contains the start button 
and appears by default at the bottom of the desktop.

 terabyte (tB): 2 to the 40th power (1,099,511,627,776) 
bytes.

 tIFF (tagged Image File Format): It stores 
compressed files with a flexible number of bits per 
pixel.

 tPS (transaction Processing System): A computer-
based information system that tracks the transactions 
needed to conduct business.

 toolbar: A row or rows of buttons on a display 
screen that are clicked on to select various functions in 
a software application or web browser.

 topology: In networking, this refers to the physical 
or logical arrangement of a network.

 trojan: A type of computer virus that is loaded 
into an unsuspecting users system via a host program 
such as a free game.

U

 Uploading: It means transmitting data from a local 
computer to a remote computer, as from your PC to a 
website you are constructing.

 UPS (Uninterruptible Power Supply): It is a 
backup power unit that provides continuous power 
when the normal power supply is interrupted.

 URL (Uniform Resource Locator): A protocol for 
specifying addresses on the Internet. It is an address 
that identifies a particular file on the Internet, usually 
consisting of the protocol as http, followed by the 
domain name.

 User-friendly: Mainly used to describe software. 
Software that is easy to use and offers guidance if the 
user does silly things is described as user-friendly.

 Utility Program: A program developed to run 
within an Operating System to perform a specific 
service.

V

 Videoconferencing or Video Conferencing: A 
computer-based communications system that allows 
a group of computer users at different locations to 

conduct a “virtual conference” in which the participants 
can see and hear one another as if they were in the 
same room participating in a real conference.

 Virus: A program or piece of code that is loaded 
onto your computer without your knowledge and 
runs against your wishes.

W

 W3C (World Wide Web Consortium): An 

international non-profit organization which acts as a 
resource centre for the World Wide Web, and is active 
in setting technical standards.

 WAV: Stands for WAVeform sound format. 
Microsoft’s format for encoding sound files.

 Webcam: A camera connected to a computer and 
linking it to the Internet.

 Web server: A computer that runs specific software 
to serve web pages to the Internet.

 Web site: A connected group of pages on the 
World Wide Web regarded as a single entity, usually 
maintained by one person or organization and 
developed to a single topic or several closely related 
topics.

 Wizard: A utility that provides guided sequence to 
perform complex task easily and quickly.

  Wikis: Webpages that can be viewed and modified 
by anyone with a Web browser and Internet access.

 Word Processor: Software that processes textual 
matter and creates organized documents.

 Workstation: The computer attached to the 
Internet.

 WWW (World Wide Web): Series of servers or 
computers that are interconnected through hypertext.

 WYSIWYG: What You Say Is What You Get.

X

 XML (eXtensible Markup Language): It is a markup 
language, not limited to Web documents.

Y

 Youtube: A website to which we can upload our 
own video clips and view video clips uploaded by 
others: http://www.youtube.com.

Z

 Zip Disks: The disks with a special high-quality 
magnetic coating that have a capacity of 100, 250 or 
750 megabytes.
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